Click for Sun
Back to Board Index

Is Teamspeak 3.5 supported?
Ricardo Trujillo
United States
1st Feb 2019
23:28:27
I\'m having problems with TeamSpeak.
From what I\'ve read in the forum, only version 2 is supported, but TeamSpeak 2 isn\'t available for download.
Dave Wave
United Kingdom

3rd Feb 2019
10:03:47
It works with TeamSpeak 3



You need to Log on to post a reply.
Back to Board Index



Forum help

No politics, just flying
FSopen © 2009 - 2017
Page views: 1093364305