Click for Sun
Back to Board Index

Open Control
Dave Wave
United Kingdom

5th Nov 2011
16:14:51
Just put first tutorial video up.



Beta might be available tomorrow
Joe Clifford
United Kingdom

5th Nov 2011
18:59:04
Look Forward To it!
Dave Wave
United Kingdom

6th Nov 2011
11:32:52
Another one.


How to create buttons

Dave Wave
United Kingdom

6th Nov 2011
13:19:23
Beta is now available to download.


http://www.fsopen.co.uk/downloads/opencontrol/
Dave Wave
United Kingdom

6th Nov 2011
16:59:35
How to use containers and text

Jon Bowles
United States

7th Nov 2011
03:35:55
Excellent work Dave!

I have just downloaded it, and had a helluva time trying to get the "Web Server" to come online. I figured out that the problem was my TeamViewer was running, at that it didn't like that port 80 was being used.

Working on my first project now! ;-) Again, CHEERS!

Jon Bowles
Dave Wave
United Kingdom

7th Nov 2011
10:40:58
Thanks for the feedback Jon.

I'll have a look to see if I can flag up clearly that something else has grabbed port 80.
Dave Wave
United Kingdom

7th Nov 2011
16:45:19
Just added the last 2 tutorials.


Put them all into a playlist.

You can watch them all in one place on this link.



http://www.youtube.com/playlist?list=PLDA862DB272A9719C
Jon Bowles
United States

10th Nov 2011
21:58:45
Nice job on the tuts!

Alright.... I am not sure if you have already fixed this, bur it's happening again, v0.1 is remaining when v0.2 installed. I just updated to v0.4 and it removed v0.2 correctly, but v0.1 remains.

Cheers!
Dave Wave
United Kingdom

10th Nov 2011
23:06:36
I think you might have picked up an early version as this wasn't happening yesterday. (Which would explain why 0.2, 0.3 are removed) Just remove 0.1 by hand and you'll be fine.
Dennis Hardy
United Kingdom
11th Nov 2011
16:11:22
Hi, just downloaded the beta and tried it out on my Android phone.
I created a file called "try 1" but the phone only showed a grey blank screen when I selected the file. I then renamed it "try1" (no space) and it worked perfectly. Same thing happened when I tried it on my laptop.
Also if Open control is started first and the FSX it does not connect to flight sim (maybe it's supposed to work this way?)

Regards

Den
Dave Wave
United Kingdom

11th Nov 2011
16:17:18
OK, it doesn't like spaces in the name. I'll fix that.

If you start open control first it should still connect to fsx after it's started. Does on both my machines.

Please can you try this after a clean re-boot.

Thanks
Dave Wave
United Kingdom

11th Nov 2011
16:31:59
Version 0.5 now released.

Fixes the problem with spaces in control names.
Also added in just about every variable possible.

Dennis Hardy
United Kingdom
11th Nov 2011
17:02:24
Now works with spaces.
After reboot connects to FSX if flight sim started second.

Thanks

Den
Dennis Hardy
United Kingdom
15th Nov 2011
14:35:01
Just playing with the DME variable functions. Noticed a typo on the dropdowns- there are 2 entries for NAV1 DME and none for NAV2 DME, but the 2nd one is NAV2 DME.
Also I can't get the NAV IDENT to display anything. I'm guessing this should show the ICAO code for NAV1 but nothing shows up in either IE or Firefox. One for NAV2 would be useful too.

Regards

Den
Steff Missot
Netherlands

15th Nov 2011
14:43:41
Hello dennis,

I've never heared of a function called NAV IDENT
Navigation beacons are not able to transmit there ID(ex. MID, CLN) So I don't think it does anything.
There is a Squawk IDENT, in our software we used squawk 0000 for squawk ident since squawk ident is not simulated in FSX.



Dennis Hardy
United Kingdom
15th Nov 2011
15:26:02
Hi Steff
This function is listed in the dropdown in the binding wizard under Avionics.
As all VOR beacons have an identification code (and a Morse identifier) which it transmits, I thought this was what the NAV ident function in Open Control was referring to. For instance Shannon airport VOR is SHA. In a glass cockpit this is displayed on the ND when it is tuned in.
When I set this up in OC the relevant box remains empty but the ID is shown in FSX on the ND.
Hope this helps.

Den
Dave Wave
United Kingdom

15th Nov 2011
15:51:28
Yes, DME2 was named wrong. Corrected for next release.

Nav Ident doesn't seem to be working. It registers ok without an error (So the value is correct). FSX is outputting a zero length string.

Will investigate further.
Dave Wave
United Kingdom

15th Nov 2011
16:02:25
Found it.

The fsx docs were wrong. Need to specify if you want NAV1 or NAV2. (Docs miss this out!)

I might make a special release with this fix!
Dave Wave
United Kingdom

15th Nov 2011
16:35:20
0.8 now available with your fixes.
Dennis Hardy
United Kingdom
15th Nov 2011
17:51:42
And it works as well!

Another suggestion- borders would look really good round the text boxes and variable boxes.
Drew Gifford
United Kingdom
6th Mar 2012
17:04:07
Hi having a slight issue with Open control was working fine until update now it has a problem with loading up on my tablet.. takes a long time to load up and after preesing button or using slider can take upto 5-10 seconds to respond on my fsx.. any ideas..
Other than that what a great addition to my fsx.. thank you
Dave Wave
United Kingdom

6th Mar 2012
18:02:20
It can take this long the first time a control is loaded. This is normal for the current version of open control and i might be able to speed up future versions.
Aiden Buch
Australia

6th May 2015
10:58:49
Hey Dave can you help me with this;

Every time I open Open Control it doesn't connect to FSX.

Any help?
Dave Wave
United Kingdom

6th May 2015
16:23:50
Are you running open control on the same pc that you have fsx running?
Aiden Buch
Australia

7th May 2015
06:43:12
Yes I am Dave. I did a reboot of the computer and the thing is still not connecting. I was playing free play. But i just got into a multilayer server and its still not connecting.
Aiden Buch
Australia

7th May 2015
06:44:46
Could you also plz upload another vid on how to set up Open Control??
Dave Wave
United Kingdom

7th May 2015
09:16:42
Sorry no, everyone else seems to be able to use it ok.
Andy Mooring
United Kingdom

8th May 2015
20:36:56
Christ has this thread been going since 5th Nov 2011? (jaw drops, forehead slapped and keels over) Happy 3 1/2 Birthday thread LOL. HAPPY TRAILS Y'ALL.



You need to Log on to post a reply.
Back to Board Index



Forum help

No politics, just flying
FSopen © 2009 - 2017
Page views: 1622772348